Page 1 of 2

I've got an interesting problem...

PostPosted: 10 May 2013, 14:58
by fluggy1218
I purchased DM through steam a week ago. It runs perfectly fine, no crashes/slowdown/anything when online. However, the only chance I have to play the game is when I have no internet. When I have no internet, the intro vids are white and it crashes with the message "can't find materials/console/background_00.vtf" I've gone through the troubleshooting on this site and have redownloaded the game 3 times! Any help for this?

Re: I've got an interesting problem...

PostPosted: 11 May 2013, 02:27
by Blín D'ñero

Re: I've got an interesting problem...

PostPosted: 12 May 2013, 01:50
by fluggy1218
Sad to say, but yes :cry: . It was a clean Steam download, and yeah it works great when I have internet. It seems as if it needs to be online to load "materials\console\background01.Vtf". I've found a workaround though, I just start the game on my laptop past the initial loading screen online, then pack up and open it back up when I get home (with no internet). It's an interesting thing that will work for now, I just haven't found a fix elsewhere so I thought I'd ask here since you're so helpful :)

Re: I've got an interesting problem...

PostPosted: 12 May 2013, 02:17
by Blín D'ñero
Ah wait... you have Steam Cloud enabled i guess?

I don't know exactly how that works because i disabled it the day it was introduced (1½ years ago?). While it's meant to be convenient, i suspect it rather introduces bugs like this.

On a sidenote, we shouldn't be discussing without even mentioning the hardware and OS. The game runs great you say, but does your laptop have enough free diskspace? Which Windows version? XP / Vista / 7 / 8 ?
Your Steam version is the very latest (May 3 2013) ?
Your Steam interface language is English?
What happens if you run Steam as an administrator?

Re: I've got an interesting problem...

PostPosted: 12 May 2013, 02:32
by Blín D'ñero
Hmm wait... i just tried to launch the game through Steam, and this is what i got:
Image

Game Content Conversion. Did that happen to you?

And yes now -after the conversion, i have your problem too! :xmad:

I have to experiment some to find a solution. Luckily i have an older healthy Steam installation on another PC...

Some big changes after the conversion: they moved the game to the Common folder, and the structure of the game's directory is different, folders are added. There now is a folder called vpks (5,43 GB) containing 40 .vpk files.

Moving binkw32.dll doesn't help.
Verifying Local Content didn't help.

The game runs perfectly in online mode, but is screwed up in offline mode. :inv:

Re: I've got an interesting problem...

PostPosted: 12 May 2013, 13:02
by Blín D'ñero
The only background01.vtf file in the new as well as the old Steam installation is this:

Image

... it has nothing to do with the game. But everything with the various Steam backgrounds (i believe it is used by SDK mods -the most recent i played was Black Mesa).
By mistake, the offline mode thinks it needs that particular picture at the start of our game.

Image

In the new installation (latest Steam and after the game's conversion), it is located at steamapps\sourcemods\BMS\materials\console
In the old one it was in steamapps\sourcemods\half-life 2 update\materials\Console

But it doesn't matter where it is located; it matters why only in offline mode it is being called, and how to make Steam stop doing that.

And even before that: why is it that -only in offline mode- at the start, the intro videos don't show up (white screen with black bars -so at least the empty spaces have the correct aspect ratio), and it is after the blanked out intro's that the game crashes completely with the [Can't find background image 'materials/console/background01.vtf'] Error! message.

Re: I've got an interesting problem...

PostPosted: 12 May 2013, 14:19
by Blín D'ñero
Sofar,
Verify Integrity of Local files does not help
Moving around binkw32.dll doesn't help.
Deleting / letting Steam recreate ClientRegistry.blob = does not help.
Deleting / letting Steam recreate the vpks folder = does not help.
Deleting / letting Steam recreate the appcache = does not help.


I have no problem launching any other Steam singleplayer game in OFFLINE mode, only Dark Messiah.

Console displays game version as "Might And Magic [build 168.62579] (Master 1.02)", so that's entirely OK.

Steam's "Don't save account credentials on this computer" option is not selected.

Steam client application Built: May 3 2013 / Steam API: v012 / Steam package versions 1367621987 / 1367621987

Steam installation location is not the default, but on a secondary hdd (in a Games > Steam directory).

System Specs:
Intel i7 920 / Asus Sabertooth x58 / 12 GB RAM / Radeon HD5870 crossfire / 6 Western Digital Black 1 TB hdd's //
Windows 7 x64 SP1 / Catalyst 13.4 WHQL

Re: I've got an interesting problem...

PostPosted: 12 May 2013, 16:15
by Blín D'ñero
I've searched and experimented studied and compared with it for about 4 hours now, while i should be spending my precious time on other things really. :eek:

Of course, the Retail version of Dark Messiah does not have such problem, ever. You should get a hold of a copy, then you're saved.
This is a Steam package issue with the game, and certainly not the first one in history...

I have just reported this on the Steam forums, referring to this thread.

Re: I've got an interesting problem...

PostPosted: 17 May 2013, 04:45
by fluggy1218
Wow, thank you for your dedication!
I think I will just look for the retail copy, it's just a shame I have to buy it twice just to play but such is life :roll:
The effort you put forth to fixing these issues is really astounding, and I'm grateful that you helped :)

Re: I've got an interesting problem...

PostPosted: 18 May 2013, 12:06
by Blín D'ñero
Good news. :)
It seems they fixed it. Just do the following:
  1. In Steam Library, right-click on the game -> Delete Local Content.
  2. Double-click the game to "play".
    Here Steam said that it needed to do a "Game Content Conversion", although it had already done that before and this time the game is even wiped out, nevertheless i let it go ahead whatever it wanted to do, and it did convert something for a minute.
  3. Then again double-click the game to "play".
    The bulk of the game is redownloaded. After completion, game will not start by itself, you must again
  4. double-click the game to play.
    Notice that the game starts as normal as can be.
  5. Go Offline.
  6. double-click the game to play.
    The game should start as normal as can be, and here it does! :thup:

I hope this works for you too!