Very odd problem with Steam version and modding...

Forum now read-only, closed for posting. For support please go to the Steam forums.

Re: Very odd problem with Steam version and modding...

Postby Blín D'ñero » 03 Apr 2009, 19:51

I tried differtent edits, and had the impression that changes did something (changed the game's behaviour) but it was all too vague to be sure. I'd rather say they did not do what one would expect. For instance: raising Player's Kick Damage from 1 to 3 did not seem to make any difference.
On the other hand, adding my own text into the credits immediately worked. :)
Maybe the various values all relate to each other in a too complicated way. Or (i guess) a certain "master" setting blocks any edit to be effective at all. I mean: player selects "Hardcore mode" and that's it. You should find a way to unblock that...
Just a thought, dunno if it's true.
Gaming PC: * Intel i7 4790K * Noctua NH-D15S * Asus Maximus VII Hero * 32 GB Corsair Dominator Platinum CMD32GX3M4A2133C9 * 2× Sapphire Radeon R9 290 Tri-X in crossfire * Dell U3010 @ 2560 x 1600 / 60Hz * Corsair AX 1200W * 7 x WD Black HDDs * Creative Soundblaster ZxR * Asus DRW F1ST * Corsair K95 RGB * Corsair M65 PRO RGB * Steelseries 9HD * Coolermaster STC T01 * Edifier S530 * Sennheiser HD598 * Windows 7 Ultimate x64 *

Workhorse PC: * Intel i7 2700K @ 4.8 Ghz * Noctua NH-D15 * Asus Maximus IV Extreme-Z * 32 GB Corsair Vengeance Pro CMY32GX3M4A1866C9 * Sapphire HD7970 crossfire * 3 x Dell U2410 @ Eyefinity 5760 x 1200 / 60Hz * Corsair HX 1000i * 7 x WD Black HDDs * Creative Soundblaster ZxR * Optiarc AD 5240S * Steelseries 7G * Razer Imperator 2012 * Steelseries 9HD * Coolermaster STC T01 * Edifier S730D * Windows 7 Ultimate x64 *

Workhorse PC 2: * Intel i7 920 @ 3.8 Ghz * Zalman CNPS9900A LED * Asus Sabertooth x58 * 24 GB Corsair Vengeance LP 1600MHz CL9 DDR3 * Sapphire R9 280X Vapor-X * 2 x Dell U2412M @ Eyefinity 2400 x 1920 / 60Hz * Corsair HX 850W * 7 x WDC WD1002FAEX * Creative Soundblaster Z * Optiarc AD 5240S * Steelseries 7G * Razer Mamba TE * Steelseries 9HD * Coolermaster STC T01 * Logitech Z-2300 * Windows 7 Ultimate x64 *
User avatar
Blín D'ñero
Site Admin
 
Posts: 7524
Joined: 17 Feb 2008
Location: Netherlands

Re: Very odd problem with Steam version and modding...

Postby DJK83 » 03 Apr 2009, 21:23

Hmm... how do I unblock it? Is there any way to repack a GCF file with my edited files, to force the game to use those new settings? Do you know what I mean?
DJK83
 
Posts: 15
Joined: 30 Mar 2009

Re: Very odd problem with Steam version and modding...

Postby Blín D'ñero » 03 Apr 2009, 21:42

Hey i don't know, i'm only guessing, hoping to set you on a new track for your investigation. :)
Gaming PC: * Intel i7 4790K * Noctua NH-D15S * Asus Maximus VII Hero * 32 GB Corsair Dominator Platinum CMD32GX3M4A2133C9 * 2× Sapphire Radeon R9 290 Tri-X in crossfire * Dell U3010 @ 2560 x 1600 / 60Hz * Corsair AX 1200W * 7 x WD Black HDDs * Creative Soundblaster ZxR * Asus DRW F1ST * Corsair K95 RGB * Corsair M65 PRO RGB * Steelseries 9HD * Coolermaster STC T01 * Edifier S530 * Sennheiser HD598 * Windows 7 Ultimate x64 *

Workhorse PC: * Intel i7 2700K @ 4.8 Ghz * Noctua NH-D15 * Asus Maximus IV Extreme-Z * 32 GB Corsair Vengeance Pro CMY32GX3M4A1866C9 * Sapphire HD7970 crossfire * 3 x Dell U2410 @ Eyefinity 5760 x 1200 / 60Hz * Corsair HX 1000i * 7 x WD Black HDDs * Creative Soundblaster ZxR * Optiarc AD 5240S * Steelseries 7G * Razer Imperator 2012 * Steelseries 9HD * Coolermaster STC T01 * Edifier S730D * Windows 7 Ultimate x64 *

Workhorse PC 2: * Intel i7 920 @ 3.8 Ghz * Zalman CNPS9900A LED * Asus Sabertooth x58 * 24 GB Corsair Vengeance LP 1600MHz CL9 DDR3 * Sapphire R9 280X Vapor-X * 2 x Dell U2412M @ Eyefinity 2400 x 1920 / 60Hz * Corsair HX 850W * 7 x WDC WD1002FAEX * Creative Soundblaster Z * Optiarc AD 5240S * Steelseries 7G * Razer Mamba TE * Steelseries 9HD * Coolermaster STC T01 * Logitech Z-2300 * Windows 7 Ultimate x64 *
User avatar
Blín D'ñero
Site Admin
 
Posts: 7524
Joined: 17 Feb 2008
Location: Netherlands

Re: Very odd problem with Steam version and modding...

Postby DJK83 » 03 Apr 2009, 22:21

Oh, okay, haha. :) Do you know of anywhere that Dark Messiah modding is still discussed? Because I really don't know what else to do here. Like I said, I don't have much experience modding Source games. I don't think I can figure this out myself...
DJK83
 
Posts: 15
Joined: 30 Mar 2009

Re: Very odd problem with Steam version and modding...

Postby Blín D'ñero » 04 Apr 2009, 00:28

Funny thing... now i replaced the edited file with the original, and replayed the game (level 1 and 2 completely, in Hardcore mode as always) from start some 4 ~ 5 times already, i strongly have the impression that my previous edits are working. I mean i can kick an enemy to death now in one kick. That's not normal. And it's doing it while i have restored the orginal settings already.
As if the game is reading from a cached configuration rather than directly from that file.

If this is true you should not expect result immediately after your edit. Reboot the PC (so the RAM and paging file get flushed) and then try.
Gaming PC: * Intel i7 4790K * Noctua NH-D15S * Asus Maximus VII Hero * 32 GB Corsair Dominator Platinum CMD32GX3M4A2133C9 * 2× Sapphire Radeon R9 290 Tri-X in crossfire * Dell U3010 @ 2560 x 1600 / 60Hz * Corsair AX 1200W * 7 x WD Black HDDs * Creative Soundblaster ZxR * Asus DRW F1ST * Corsair K95 RGB * Corsair M65 PRO RGB * Steelseries 9HD * Coolermaster STC T01 * Edifier S530 * Sennheiser HD598 * Windows 7 Ultimate x64 *

Workhorse PC: * Intel i7 2700K @ 4.8 Ghz * Noctua NH-D15 * Asus Maximus IV Extreme-Z * 32 GB Corsair Vengeance Pro CMY32GX3M4A1866C9 * Sapphire HD7970 crossfire * 3 x Dell U2410 @ Eyefinity 5760 x 1200 / 60Hz * Corsair HX 1000i * 7 x WD Black HDDs * Creative Soundblaster ZxR * Optiarc AD 5240S * Steelseries 7G * Razer Imperator 2012 * Steelseries 9HD * Coolermaster STC T01 * Edifier S730D * Windows 7 Ultimate x64 *

Workhorse PC 2: * Intel i7 920 @ 3.8 Ghz * Zalman CNPS9900A LED * Asus Sabertooth x58 * 24 GB Corsair Vengeance LP 1600MHz CL9 DDR3 * Sapphire R9 280X Vapor-X * 2 x Dell U2412M @ Eyefinity 2400 x 1920 / 60Hz * Corsair HX 850W * 7 x WDC WD1002FAEX * Creative Soundblaster Z * Optiarc AD 5240S * Steelseries 7G * Razer Mamba TE * Steelseries 9HD * Coolermaster STC T01 * Logitech Z-2300 * Windows 7 Ultimate x64 *
User avatar
Blín D'ñero
Site Admin
 
Posts: 7524
Joined: 17 Feb 2008
Location: Netherlands

Re: Very odd problem with Steam version and modding...

Postby DJK83 » 04 Apr 2009, 09:40

Woah, that's weird... I'll try rebooting and then start the game for the first time with the edited file...
DJK83
 
Posts: 15
Joined: 30 Mar 2009

Re: Very odd problem with Steam version and modding...

Postby DJK83 » 05 Apr 2009, 01:04

Okay, I tried rebooting after putting in my edited mm_game_settings.txt (several times), and it still doesn't seem to be working. What's weird is, occasionally during my testing, I kill an enemy or knock them down with a power attack, and they don't go flying at all, and for a moment I think my changes have taken effect. But then the ragdolls go back to flying all over the place. Plus, the unawareness multiplier never seems to take effect -- I have it set to 9, yet I still can't kill that black guard with his back turned in one hit.

You said your changes didn't take effect until after you put the original file back in... can you describe exactly what you did?
DJK83
 
Posts: 15
Joined: 30 Mar 2009

Re: Very odd problem with Steam version and modding...

Postby Blín D'ñero » 05 Apr 2009, 19:15

Well, nothing special. First i copied the original. Then started editing, saved, closed, and started the game (eveytime a new game). After i was done experimenting, i renamed the edited version, and named the copy back to the original.
Gaming PC: * Intel i7 4790K * Noctua NH-D15S * Asus Maximus VII Hero * 32 GB Corsair Dominator Platinum CMD32GX3M4A2133C9 * 2× Sapphire Radeon R9 290 Tri-X in crossfire * Dell U3010 @ 2560 x 1600 / 60Hz * Corsair AX 1200W * 7 x WD Black HDDs * Creative Soundblaster ZxR * Asus DRW F1ST * Corsair K95 RGB * Corsair M65 PRO RGB * Steelseries 9HD * Coolermaster STC T01 * Edifier S530 * Sennheiser HD598 * Windows 7 Ultimate x64 *

Workhorse PC: * Intel i7 2700K @ 4.8 Ghz * Noctua NH-D15 * Asus Maximus IV Extreme-Z * 32 GB Corsair Vengeance Pro CMY32GX3M4A1866C9 * Sapphire HD7970 crossfire * 3 x Dell U2410 @ Eyefinity 5760 x 1200 / 60Hz * Corsair HX 1000i * 7 x WD Black HDDs * Creative Soundblaster ZxR * Optiarc AD 5240S * Steelseries 7G * Razer Imperator 2012 * Steelseries 9HD * Coolermaster STC T01 * Edifier S730D * Windows 7 Ultimate x64 *

Workhorse PC 2: * Intel i7 920 @ 3.8 Ghz * Zalman CNPS9900A LED * Asus Sabertooth x58 * 24 GB Corsair Vengeance LP 1600MHz CL9 DDR3 * Sapphire R9 280X Vapor-X * 2 x Dell U2412M @ Eyefinity 2400 x 1920 / 60Hz * Corsair HX 850W * 7 x WDC WD1002FAEX * Creative Soundblaster Z * Optiarc AD 5240S * Steelseries 7G * Razer Mamba TE * Steelseries 9HD * Coolermaster STC T01 * Logitech Z-2300 * Windows 7 Ultimate x64 *
User avatar
Blín D'ñero
Site Admin
 
Posts: 7524
Joined: 17 Feb 2008
Location: Netherlands

Re: Very odd problem with Steam version and modding...

Postby DJK83 » 05 Apr 2009, 23:54

Did you reboot in between, or did you immediately start the game again, only to have the changes you'd made suddenly take effect?
DJK83
 
Posts: 15
Joined: 30 Mar 2009

Re: Very odd problem with Steam version and modding...

Postby Blín D'ñero » 06 Apr 2009, 02:16

No reboot. Later when i restarted the PC and launched the game, i had the impression the game behaved differently.
Gaming PC: * Intel i7 4790K * Noctua NH-D15S * Asus Maximus VII Hero * 32 GB Corsair Dominator Platinum CMD32GX3M4A2133C9 * 2× Sapphire Radeon R9 290 Tri-X in crossfire * Dell U3010 @ 2560 x 1600 / 60Hz * Corsair AX 1200W * 7 x WD Black HDDs * Creative Soundblaster ZxR * Asus DRW F1ST * Corsair K95 RGB * Corsair M65 PRO RGB * Steelseries 9HD * Coolermaster STC T01 * Edifier S530 * Sennheiser HD598 * Windows 7 Ultimate x64 *

Workhorse PC: * Intel i7 2700K @ 4.8 Ghz * Noctua NH-D15 * Asus Maximus IV Extreme-Z * 32 GB Corsair Vengeance Pro CMY32GX3M4A1866C9 * Sapphire HD7970 crossfire * 3 x Dell U2410 @ Eyefinity 5760 x 1200 / 60Hz * Corsair HX 1000i * 7 x WD Black HDDs * Creative Soundblaster ZxR * Optiarc AD 5240S * Steelseries 7G * Razer Imperator 2012 * Steelseries 9HD * Coolermaster STC T01 * Edifier S730D * Windows 7 Ultimate x64 *

Workhorse PC 2: * Intel i7 920 @ 3.8 Ghz * Zalman CNPS9900A LED * Asus Sabertooth x58 * 24 GB Corsair Vengeance LP 1600MHz CL9 DDR3 * Sapphire R9 280X Vapor-X * 2 x Dell U2412M @ Eyefinity 2400 x 1920 / 60Hz * Corsair HX 850W * 7 x WDC WD1002FAEX * Creative Soundblaster Z * Optiarc AD 5240S * Steelseries 7G * Razer Mamba TE * Steelseries 9HD * Coolermaster STC T01 * Logitech Z-2300 * Windows 7 Ultimate x64 *
User avatar
Blín D'ñero
Site Admin
 
Posts: 7524
Joined: 17 Feb 2008
Location: Netherlands

PreviousNext

Return to Dark Messiah of Might and Magic

Who is online

Users browsing this forum: No registered users and 3 guests

cron