SteamCMD does not work for Dark Messiah Dedicated Server. Files are buggy!

Forum now read-only, closed for posting. For support please go to the Steam forums.

SteamCMD does not work for Dark Messiah Dedicated Server. Files are buggy!

Postby woochy » 19 Jan 2015, 13:57

There are only 3 servers in the game, but they don't show up in main server browser. It's not really a big deal, because servers can be added to favourites manually by copy+paste; but the most compelling part is that, there's no support from SteamCMD for dedicated server of this game. Server files are buggy.

These are steps, which I took to try to launch my own server.


Now, my question is.. how to make my server working? Is it even possible? The funny thing is that I tried also to download Dark Messiah Dedicated Server from Steam platform and experienced the same errors as for SteamCMD. However, server console opens somehow only if I click on shortcut from Tools list in Steam platform. I don't know how is it possible, but it's not good way in long term, because I've already paid for the server to provider. I doubt they'll want to install Steam directly to my server directory and play with shortcuts etc. I guess they experienced the same thing as me and met with the same issues, so I would be glad if you could tell me how to solve this problem. Could you tell me if you know the fix?

Please reply as soon as possible.
woochy
 
Posts: 4
Joined: 19 Jan 2015

Re: SteamCMD does not work for Dark Messiah Dedicated Server. Files are buggy!

Postby woochy » 19 Jan 2015, 16:51

Hello again,

I played a lil bit with files and no errors show up. Currently I met with the problem with lack of default maps. Even server directory didnt have maps folder, so I created a new one and putted all default maps with .bsp format and now, console opens for a few secs and automaticaly closes.

My command line for srcds.exe shorcut is:
Code: Select all
-console -condebug +maxplayers 16 +map ctf_3 +exec server.cfg


Console window just before closing looks like: http://i58.tinypic.com/xf2qmo.jpg

My server.cfg:

Code: Select all
log on                //Creates a logfile (Enable= on Disable= off)
sv_logfile 1            //Log server information in the log file.
sv_logsdir F:\SRCDS\cstrike\logs    //Folder in the game directory where server logs will be stored.

sv_logecho 0            //Echo log information to the console.

sv_log_onefile 1        //Log server information to only one file.
sv_logbans 1            //Log server bans in the server logs.
sv_logdownloadlist 1        //Log files to download.

My console.log:

Code: Select all
maxplayers set to 32
maxplayers set to 16
Server logging enabled.
Server logging data to file logs\L0119017.log
L 01/19/2015 - 16:43:32: Log file started (file "logs\L0119017.log") (game "D:\Program Files (x86)\Steam\steamapps\common\Dark Messiah Might and Magic Dedicated Server") (version "1")


My log file from logs:

Code: Select all
L 01/19/2015 - 16:44:13: Log file started (file "logs\L0119000.log") (game "D:\Program Files (x86)\Steam\steamapps\common\Dark Messiah Might and Magic Dedicated Server") (version "1")
L 01/19/2015 - 16:44:13: Loading map "ctf_3"
L 01/19/2015 - 16:44:13: server cvars start
L 01/19/2015 - 16:44:13: "mp_gametype" = "2"
L 01/19/2015 - 16:44:13: "mp_fraglimit" = "30"
L 01/19/2015 - 16:44:13: "mp_falldamage" = "1"
L 01/19/2015 - 16:44:13: "mp_weaponstay" = "0"
L 01/19/2015 - 16:44:13: "mp_forcerespawn" = "1"
L 01/19/2015 - 16:44:13: "mp_footsteps" = "1"
L 01/19/2015 - 16:44:13: "mp_flashlight" = "0"
L 01/19/2015 - 16:44:13: "mp_autocrosshair" = "1"
L 01/19/2015 - 16:44:13: "decalfrequency" = "10"
L 01/19/2015 - 16:44:13: "mp_teamlist" = "hgrunt;scientist"
L 01/19/2015 - 16:44:13: "mp_allowNPCs" = "1"
L 01/19/2015 - 16:44:13: "mp_friendlyfire" = "1"
L 01/19/2015 - 16:44:13: "sv_gravity" = "600"
L 01/19/2015 - 16:44:13: "sv_stopspeed" = "100"
L 01/19/2015 - 16:44:13: "sv_noclipaccelerate" = "5"
L 01/19/2015 - 16:44:13: "sv_noclipspeed" = "5"
L 01/19/2015 - 16:44:13: "sv_specaccelerate" = "5"
L 01/19/2015 - 16:44:13: "sv_specspeed" = "3"
L 01/19/2015 - 16:44:13: "sv_specnoclip" = "1"
L 01/19/2015 - 16:44:13: "sv_maxspeed" = "450"
L 01/19/2015 - 16:44:13: "sv_accelerate" = "10"
L 01/19/2015 - 16:44:13: "sv_airaccelerate" = "10"
L 01/19/2015 - 16:44:13: "sv_wateraccelerate" = "10"
L 01/19/2015 - 16:44:13: "sv_waterfriction" = "1"
L 01/19/2015 - 16:44:13: "sv_footsteps" = "1"
L 01/19/2015 - 16:44:13: "sv_rollspeed" = "200"
L 01/19/2015 - 16:44:13: "sv_rollangle" = "0"
L 01/19/2015 - 16:44:13: "sv_friction" = "4"
L 01/19/2015 - 16:44:13: "sv_bounce" = "0"
L 01/19/2015 - 16:44:13: "sv_stepsize" = "18"
L 01/19/2015 - 16:44:13: "r_VehicleViewDampen" = "1"
L 01/19/2015 - 16:44:13: "mp_timelimit" = "15"
L 01/19/2015 - 16:44:13: "mp_campaigntimelimit" = "30"
L 01/19/2015 - 16:44:13: "mp_numrounds" = "0"
L 01/19/2015 - 16:44:13: "mp_colteamsize" = "1"
L 01/19/2015 - 16:44:13: "mp_colcombattime" = "2.0"
L 01/19/2015 - 16:44:13: "mp_colwinlimit" = "1000"
L 01/19/2015 - 16:44:13: "mp_colwarmuptime" = "15.0"
L 01/19/2015 - 16:44:13: "xp_gain_force_arrow" = "2"
L 01/19/2015 - 16:44:13: "map_initial_tickets" = "100"
L 01/19/2015 - 16:44:13: "ubi_tracking_system" = "1"
L 01/19/2015 - 16:44:13: "sv_alltalk" = "0"
L 01/19/2015 - 16:44:13: "sv_hl2mp_weapon_respawn_time" = "20"
L 01/19/2015 - 16:44:13: "sv_hl2mp_item_respawn_time" = "30"
L 01/19/2015 - 16:44:13: "cp_graceperiod" = "1"
L 01/19/2015 - 16:44:13: "sv_voiceenable" = "1"
L 01/19/2015 - 16:44:13: "sv_pausable" = "0"
L 01/19/2015 - 16:44:13: "sv_cheats" = "0"
L 01/19/2015 - 16:44:13: "coop" = "0"
L 01/19/2015 - 16:44:13: "deathmatch" = "1"
L 01/19/2015 - 16:44:13: "tv_relaypassword" = ""
L 01/19/2015 - 16:44:13: "tv_password" = ""
L 01/19/2015 - 16:44:13: "sv_password" = ""
L 01/19/2015 - 16:44:13: server cvars end


I still cant find the solution. Why it does not work? Why server does not launch? I will appreciate any help, because I am really out of ideas. I spent on this 2 days and it is still corrupted. What is going on?
woochy
 
Posts: 4
Joined: 19 Jan 2015

Re: SteamCMD does not work for Dark Messiah Dedicated Server. Files are buggy!

Postby Blín D'ñero » 20 Jan 2015, 04:15

Hi
Have you tried with Steam interface language set to English?

For the rest this link might be useful: Source Dedicated Server
Gaming PC: * Intel i7 4790K * Noctua NH-D15S * Asus Maximus VII Hero * 32 GB Corsair Dominator Platinum CMD32GX3M4A2133C9 * 2× Sapphire Radeon R9 290 Tri-X in crossfire * Dell U3010 @ 2560 x 1600 / 60Hz * Corsair AX 1200W * 7 x WD Black HDDs * Creative Soundblaster ZxR * Asus DRW F1ST * Corsair K95 RGB * Corsair M65 PRO RGB * Steelseries 9HD * Coolermaster STC T01 * Edifier S530 * Sennheiser HD598 * Windows 7 Ultimate x64 *

Workhorse PC: * Intel i7 2700K @ 4.8 Ghz * Noctua NH-D15 * Asus Maximus IV Extreme-Z * 32 GB Corsair Vengeance Pro CMY32GX3M4A1866C9 * Sapphire HD7970 crossfire * 3 x Dell U2410 @ Eyefinity 5760 x 1200 / 60Hz * Corsair HX 1000i * 7 x WD Black HDDs * Creative Soundblaster ZxR * Optiarc AD 5240S * Steelseries 7G * Razer Imperator 2012 * Steelseries 9HD * Coolermaster STC T01 * Edifier S730D * Windows 7 Ultimate x64 *

Workhorse PC 2: * Intel i7 920 @ 3.8 Ghz * Zalman CNPS9900A LED * Asus Sabertooth x58 * 24 GB Corsair Vengeance LP 1600MHz CL9 DDR3 * Sapphire R9 280X Vapor-X * 2 x Dell U2412M @ Eyefinity 2400 x 1920 / 60Hz * Corsair HX 850W * 7 x WDC WD1002FAEX * Creative Soundblaster Z * Optiarc AD 5240S * Steelseries 7G * Razer Mamba TE * Steelseries 9HD * Coolermaster STC T01 * Logitech Z-2300 * Windows 7 Ultimate x64 *
User avatar
Blín D'ñero
Site Admin
 
Posts: 7261
Joined: 17 Feb 2008
Location: Netherlands

Re: SteamCMD does not work for Dark Messiah Dedicated Server. Files are buggy!

Postby woochy » 20 Jan 2015, 09:33

Blín D'ñero wrote:Hi
Have you tried with Steam interface language set to English?

For the rest this link might be useful: Source Dedicated Server


I have already Steam interface in English.

This link is outdated, because installation says about downloading hldsupdate tool, but hlds servers are shut and Steam changed it into SteamCMD. As you can see in my first post, I've downloaded SteamCMD, configured for Dark Messiah Dedicated Server needs and downloaded whole server content.

You know, the problem is not launching the DMDS from Steam Tools list, but the problem is how to launch it from server directory. My server provider has access only to server files and nothing else. I doubt, they'll want to install Steam to my server FTP, because it'll required Steam.exe runnning in the background.
woochy
 
Posts: 4
Joined: 19 Jan 2015

Re: SteamCMD does not work for Dark Messiah Dedicated Server. Files are buggy!

Postby woochy » 21 Jan 2015, 10:38

Ok, I have finally found the fix.

So the fix was to get the files from the dedicated server tool, extract some of the VPKS files from the game and then past these files over the top of the orginal files, once this is done the server will start working but it wont connect to steam, so you need to take all the DLL files from the steamcmd folder and past them over the top of the files in the Bin folder.
woochy
 
Posts: 4
Joined: 19 Jan 2015


Return to Dark Messiah of Might and Magic

Who is online

Users browsing this forum: No registered users and 2 guests

cron