Eyefinity issue

Get assistance for technical problems with your PC. Or share your insights.

Eyefinity issue

Postby Blín D'ñero » 06 Sep 2015, 15:38

Invited by this post AMD Needs Your Help - Requesting Feedback for Catalyst Driver,


I filled in the form this issue:

One out of three six times, after a fresh boot, or reboot, my Eyefinity setup is broken: only the right monitor (3) will have the taskbar. So screen 3 has become 1, screen 1 and 2 have become 2 and 3.

I then have to power off the MST-Hub, and after i hear the Windows' sound of disconnect, power it back on, and CCC restores my original Eyefinity setup.

Very annoying, because the result then is (i have 'restore windows at logon' enabled), that all (20 or more) Explorer / Internet Explorer windows i had open get resized to the exact same small dimensions and stacked ontop of each other in the top left corner of the left monitor. And i have to unstack, resize and redistribute all of them again over the three screens where they were before, so i can continue working as usual.

Catalyst Version 15.7.1
And all Catalysts from 14.4 and up.

Sapphire R9 280X Vapor-X
Monitors = 3 x Dell U2410 in landscape 5760 x 1200.
Connection: DisplayPort output on card -> Club3D CSV-5300 MST-Hub -> DisplayPort (native) input on all 3 monitors.

My "Workhorse" PC specs:
Workhorse PC: * Intel i7 920 @ 3.8 Ghz * Zalman CNPS9900 LED * Asus Sabertooth x58 * 24 GB Corsair Vengeance LP 1600MHz CL9 DDR3 * Sapphire R9 280X Vapor-X * 3 x Dell U2410 @ Eyefinity 5760 x 1200 / 60Hz * Corsair HX 850W * 7 x WDC WD1002FAEX * Creative X-Fi Titanium Fatality Pro * Optiarc AD 5240S * Steelseries 7G * Logitech G9 * Steelseries SX * Coolermaster STC T01 * Edifier S530 * Windows 7 Ultimate x64 *
Gaming PC: * Intel i7 4790K * Noctua NH-D15S * Asus Maximus VII Hero * 32 GB Corsair Dominator Platinum CMD32GX3M4A2133C9 * 2× Sapphire Radeon R9 290 Tri-X in crossfire * Dell U3010 @ 2560 x 1600 / 60Hz * Corsair AX 1200W * 7 x WD Black HDDs * Creative Soundblaster ZxR * Asus DRW F1ST * Corsair K95 RGB * Corsair M65 PRO RGB * Steelseries 9HD * Coolermaster STC T01 * Edifier S530 * Sennheiser HD598 * Windows 7 Ultimate x64 *

Workhorse PC: * Intel i7 2700K @ 4.8 Ghz * Noctua NH-D15 * Asus Maximus IV Extreme-Z * 32 GB Corsair Vengeance Pro CMY32GX3M4A1866C9 * Sapphire HD7970 crossfire * 3 x Dell U2410 @ Eyefinity 5760 x 1200 / 60Hz * Corsair HX 1000i * 7 x WD Black HDDs * Creative Soundblaster ZxR * Optiarc AD 5240S * Steelseries 7G * Razer Imperator 2012 * Steelseries 9HD * Coolermaster STC T01 * Edifier S730D * Windows 7 Ultimate x64 *

Workhorse PC 2: * Intel i7 920 @ 3.8 Ghz * Zalman CNPS9900A LED * Asus Sabertooth x58 * 24 GB Corsair Vengeance LP 1600MHz CL9 DDR3 * Sapphire R9 280X Vapor-X * 2 x Dell U2412M @ Eyefinity 2400 x 1920 / 60Hz * Corsair HX 850W * 7 x WDC WD1002FAEX * Creative Soundblaster Z * Optiarc AD 5240S * Steelseries 7G * Razer Mamba TE * Steelseries 9HD * Coolermaster STC T01 * Logitech Z-2300 * Windows 7 Ultimate x64 *
User avatar
Blín D'ñero
Site Admin
 
Posts: 7264
Joined: 17 Feb 2008
Location: Netherlands

Re: Eyefinity issue

Postby Blín D'ñero » 07 Sep 2015, 14:21

Naa... it's probably one out of six times. So not that often, but it happens.

I have 'restore windows at logon' enabled. At the moment i have twelve Explorer windows open, distributed over the 3 screens. Normally, they would all restore to the exact same place after cold boot or reboot.
Gaming PC: * Intel i7 4790K * Noctua NH-D15S * Asus Maximus VII Hero * 32 GB Corsair Dominator Platinum CMD32GX3M4A2133C9 * 2× Sapphire Radeon R9 290 Tri-X in crossfire * Dell U3010 @ 2560 x 1600 / 60Hz * Corsair AX 1200W * 7 x WD Black HDDs * Creative Soundblaster ZxR * Asus DRW F1ST * Corsair K95 RGB * Corsair M65 PRO RGB * Steelseries 9HD * Coolermaster STC T01 * Edifier S530 * Sennheiser HD598 * Windows 7 Ultimate x64 *

Workhorse PC: * Intel i7 2700K @ 4.8 Ghz * Noctua NH-D15 * Asus Maximus IV Extreme-Z * 32 GB Corsair Vengeance Pro CMY32GX3M4A1866C9 * Sapphire HD7970 crossfire * 3 x Dell U2410 @ Eyefinity 5760 x 1200 / 60Hz * Corsair HX 1000i * 7 x WD Black HDDs * Creative Soundblaster ZxR * Optiarc AD 5240S * Steelseries 7G * Razer Imperator 2012 * Steelseries 9HD * Coolermaster STC T01 * Edifier S730D * Windows 7 Ultimate x64 *

Workhorse PC 2: * Intel i7 920 @ 3.8 Ghz * Zalman CNPS9900A LED * Asus Sabertooth x58 * 24 GB Corsair Vengeance LP 1600MHz CL9 DDR3 * Sapphire R9 280X Vapor-X * 2 x Dell U2412M @ Eyefinity 2400 x 1920 / 60Hz * Corsair HX 850W * 7 x WDC WD1002FAEX * Creative Soundblaster Z * Optiarc AD 5240S * Steelseries 7G * Razer Mamba TE * Steelseries 9HD * Coolermaster STC T01 * Logitech Z-2300 * Windows 7 Ultimate x64 *
User avatar
Blín D'ñero
Site Admin
 
Posts: 7264
Joined: 17 Feb 2008
Location: Netherlands

Re: Eyefinity issue

Postby Blín D'ñero » 03 Oct 2015, 23:57

A new variation, since Catalyst 15.9.1 Beta.

(And i switched systems, it's now with 2×HD7970 instead of one R9 280X but it's essentially the same card and crossfire doesn't matter in 2D)

When starting up, one of the three screens may stay black. Or even all three (it just happened)! Until i power-off the MST-Hub (hear Windows sound of 'hardware disconnected'), and back on again to restore my 3-screen Eyefinity.

But the variation, the "new thing" now is, that the previous open windows are NOT anymore stacked on top of each other in the top left corner of desktop, they are now where they were, where they belong and are expected. :) I have seen this several times now since i installed this new driver.

So it seems that some fixing has been done on the issue, just not a full fix.

[2× Sapphire Radeon HD7970 reference
Monitors = 3 x Dell U2410 in landscape 5760 x 1200.
Connection: DisplayPort output on card -> Club3D CSV-5300 MST-Hub -> DisplayPort (native) input on all 3 monitors.]


I don't see it mentioned in the Catalyst 15.9.1 Beta fixed or known issues either. So i guess it's known but they're still working on it...
Gaming PC: * Intel i7 4790K * Noctua NH-D15S * Asus Maximus VII Hero * 32 GB Corsair Dominator Platinum CMD32GX3M4A2133C9 * 2× Sapphire Radeon R9 290 Tri-X in crossfire * Dell U3010 @ 2560 x 1600 / 60Hz * Corsair AX 1200W * 7 x WD Black HDDs * Creative Soundblaster ZxR * Asus DRW F1ST * Corsair K95 RGB * Corsair M65 PRO RGB * Steelseries 9HD * Coolermaster STC T01 * Edifier S530 * Sennheiser HD598 * Windows 7 Ultimate x64 *

Workhorse PC: * Intel i7 2700K @ 4.8 Ghz * Noctua NH-D15 * Asus Maximus IV Extreme-Z * 32 GB Corsair Vengeance Pro CMY32GX3M4A1866C9 * Sapphire HD7970 crossfire * 3 x Dell U2410 @ Eyefinity 5760 x 1200 / 60Hz * Corsair HX 1000i * 7 x WD Black HDDs * Creative Soundblaster ZxR * Optiarc AD 5240S * Steelseries 7G * Razer Imperator 2012 * Steelseries 9HD * Coolermaster STC T01 * Edifier S730D * Windows 7 Ultimate x64 *

Workhorse PC 2: * Intel i7 920 @ 3.8 Ghz * Zalman CNPS9900A LED * Asus Sabertooth x58 * 24 GB Corsair Vengeance LP 1600MHz CL9 DDR3 * Sapphire R9 280X Vapor-X * 2 x Dell U2412M @ Eyefinity 2400 x 1920 / 60Hz * Corsair HX 850W * 7 x WDC WD1002FAEX * Creative Soundblaster Z * Optiarc AD 5240S * Steelseries 7G * Razer Mamba TE * Steelseries 9HD * Coolermaster STC T01 * Logitech Z-2300 * Windows 7 Ultimate x64 *
User avatar
Blín D'ñero
Site Admin
 
Posts: 7264
Joined: 17 Feb 2008
Location: Netherlands

Re: Eyefinity issue

Postby Blín D'ñero » 07 Oct 2015, 19:37

A new variation on this issue today:
After starting up, fully loaded Windows desktop is:
Left monitor shows up 1920×1200 as it should, has all the icons, but no taskbar at the bottom. Center monitor shows up 800 × 600 resolution, with a big fat taskbar. Right monitor is black.

Of course, i power off the MST-Hub, and after i hear the Windows' sound of disconnect, power it back on, and CCC has restored my original Eyefinity setup.

I had power configuration of monitor (= go to sleep after) set to 45 minutes. An hour later i move the mouse, and only the right-side monitor wakes up.... :roll:

Since then i have it set to 1 minute. Eyefinity woke up correctly for several times now.

But it should work correctly always, at all settings!

Catalyst 15.9.1. Beta.

[EDIT:
i left that PC on with the monitors sleeping for 8 hours, power still set to 1 minute.
Moved the mouse to wake them up, and only the right side monitor woke up.

/EDIT]
Gaming PC: * Intel i7 4790K * Noctua NH-D15S * Asus Maximus VII Hero * 32 GB Corsair Dominator Platinum CMD32GX3M4A2133C9 * 2× Sapphire Radeon R9 290 Tri-X in crossfire * Dell U3010 @ 2560 x 1600 / 60Hz * Corsair AX 1200W * 7 x WD Black HDDs * Creative Soundblaster ZxR * Asus DRW F1ST * Corsair K95 RGB * Corsair M65 PRO RGB * Steelseries 9HD * Coolermaster STC T01 * Edifier S530 * Sennheiser HD598 * Windows 7 Ultimate x64 *

Workhorse PC: * Intel i7 2700K @ 4.8 Ghz * Noctua NH-D15 * Asus Maximus IV Extreme-Z * 32 GB Corsair Vengeance Pro CMY32GX3M4A1866C9 * Sapphire HD7970 crossfire * 3 x Dell U2410 @ Eyefinity 5760 x 1200 / 60Hz * Corsair HX 1000i * 7 x WD Black HDDs * Creative Soundblaster ZxR * Optiarc AD 5240S * Steelseries 7G * Razer Imperator 2012 * Steelseries 9HD * Coolermaster STC T01 * Edifier S730D * Windows 7 Ultimate x64 *

Workhorse PC 2: * Intel i7 920 @ 3.8 Ghz * Zalman CNPS9900A LED * Asus Sabertooth x58 * 24 GB Corsair Vengeance LP 1600MHz CL9 DDR3 * Sapphire R9 280X Vapor-X * 2 x Dell U2412M @ Eyefinity 2400 x 1920 / 60Hz * Corsair HX 850W * 7 x WDC WD1002FAEX * Creative Soundblaster Z * Optiarc AD 5240S * Steelseries 7G * Razer Mamba TE * Steelseries 9HD * Coolermaster STC T01 * Logitech Z-2300 * Windows 7 Ultimate x64 *
User avatar
Blín D'ñero
Site Admin
 
Posts: 7264
Joined: 17 Feb 2008
Location: Netherlands

Re: Eyefinity issue

Postby Blín D'ñero » 08 Oct 2015, 15:20

So, resuming.

The issue:
- > One out of three or four times, after a fresh boot or reboot, my Eyefinity setup is broken: only the right monitor (3) will have the taskbar. So screen 3 has become 1, screen 1 and 2 have become 2 and 3.

I then have to power off the MST-Hub, and after i hear the Windows' sound of disconnect, power it back on, and CCC restores my original Eyefinity setup.

- > Or, when starting up, one of the three screens may stay black. Or even all three! Until i power-off the MST-Hub (hear Windows sound of 'hardware disconnected'), and back on again to restore my 3-screen Eyefinity.

- > Or, after starting up, fully loaded Windows desktop is:
Left monitor is 1920×1200, has all the icons but no taskbar at the bottom. Center monitor is 800 × 600 resolution, with a big fat taskbar. Right monitor is black.

Of course, i power off the MST-Hub, and after i hear the Windows' sound of disconnect, power it back on, and CCC has restored my original Eyefinity setup.

- > I had 'go to sleep' for monitor set to 45 minutes. An hour later i move the mouse, and only the right-side monitor wakes up.... :roll:

Since then i have it set to 1 minute. Eyefinity woke up correctly for several times now. But it should work correctly always, at all settings!

- > I left that PC on with the monitors sleeping for 8 hours, power still set to 1 minute.
Moved the mouse to wake them up, and only the right side monitor woke up.

Catalyst 15.9.1. Beta.
I personally have noticed this issue from Catalyst 14.4 and up.
I have 'restore windows at logon' enabled. The "new thing" with these latest Catalyst drivers (i went from 15.7.1 to 15.9.1) is, that the previous open windows are NOT anymore stacked on top of each other in the top left corner of desktop, they are now where they were before, where they belong and are expected. :)
So it seems that SOME attempt at fixing has been done on the issue, just not a full fix yet.

Sapphire HD7970 crossfire.
Monitors = 3 x Dell U2410 in landscape 5760 x 1200.
Connection: DisplayPort output on card -> Club3D CSV-5300 MST-Hub -> DisplayPort (native) input on all 3 monitors.

Intel i7 2700K
motherboard: Asus Maximus IV Extreme-Z
BIOS: v3510
System memory: 32 GB Corsair Vengeance Pro CMY32GX3M4A1866C9
PSU wattage: 1000 W
Gaming PC: * Intel i7 4790K * Noctua NH-D15S * Asus Maximus VII Hero * 32 GB Corsair Dominator Platinum CMD32GX3M4A2133C9 * 2× Sapphire Radeon R9 290 Tri-X in crossfire * Dell U3010 @ 2560 x 1600 / 60Hz * Corsair AX 1200W * 7 x WD Black HDDs * Creative Soundblaster ZxR * Asus DRW F1ST * Corsair K95 RGB * Corsair M65 PRO RGB * Steelseries 9HD * Coolermaster STC T01 * Edifier S530 * Sennheiser HD598 * Windows 7 Ultimate x64 *

Workhorse PC: * Intel i7 2700K @ 4.8 Ghz * Noctua NH-D15 * Asus Maximus IV Extreme-Z * 32 GB Corsair Vengeance Pro CMY32GX3M4A1866C9 * Sapphire HD7970 crossfire * 3 x Dell U2410 @ Eyefinity 5760 x 1200 / 60Hz * Corsair HX 1000i * 7 x WD Black HDDs * Creative Soundblaster ZxR * Optiarc AD 5240S * Steelseries 7G * Razer Imperator 2012 * Steelseries 9HD * Coolermaster STC T01 * Edifier S730D * Windows 7 Ultimate x64 *

Workhorse PC 2: * Intel i7 920 @ 3.8 Ghz * Zalman CNPS9900A LED * Asus Sabertooth x58 * 24 GB Corsair Vengeance LP 1600MHz CL9 DDR3 * Sapphire R9 280X Vapor-X * 2 x Dell U2412M @ Eyefinity 2400 x 1920 / 60Hz * Corsair HX 850W * 7 x WDC WD1002FAEX * Creative Soundblaster Z * Optiarc AD 5240S * Steelseries 7G * Razer Mamba TE * Steelseries 9HD * Coolermaster STC T01 * Logitech Z-2300 * Windows 7 Ultimate x64 *
User avatar
Blín D'ñero
Site Admin
 
Posts: 7264
Joined: 17 Feb 2008
Location: Netherlands


Return to PC Tech Issues and Support

Who is online

Users browsing this forum: No registered users and 1 guest

cron